注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

新疆伊犁 水蓝影像

塞外蓝影风景如画

 
 
 

日志

 
 

【引用】经典路由器配置实例  

2012-01-10 22:16:48|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
本文转载自飞火流萤《经典路由器配置实例》

某公司有三个部门,财务部、销售部以及市场部。搭建网络时候的要求是:财务部能够访问另外两个部门;另外两个部门能够互访但是不能访问财务部;实现所有的内部机器上网。公司现在有一台2621路由器、一台交换机、若干集线器。

第一步 实现三个部门互访

路由器的配置

1.配置外网ip

R1(config)#in s1/0

R1(config-if)#ip add 202.88.88.88 255.255.255.0

R1(config-if)#no shut

%LINK-3-UPDOWN: Interface Serial1/0, changed state to up

R1(config-if)#exi

%LINK-3-UPDOWN: Interface Serial1/0, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down

2.启用f0/0端口,启用3个子接口

R1(config)#in f0/0

R1(config-if)#no ip add

R1(config-if)#no shut

%LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

R1(config-if)#exi

R1(config)#in f0/0.1

R1(config-subif)#ip add 192.168.1.1 255.255.255.0

R1(config-subif)#encapsulation dot1q 10

R1(config-subif)#no shut

R1(config-subif)#exi

R1(config)#in f0/0.2

R1(config-subif)#ip add 192.168.2.1 255.255.255.0

R1(config-subif)#encapsulation dot1q 20

R1(config-subif)#no shut

R1(config-subif)#exi

R1(config)#in f0/0.3

R1(config-subif)#ip add 192.168.3.1 255.255.255.0

R1(config-subif)#encapsulation dot1q 30

R1(config-subif)#no shut

R1(config-subif)#exi

交换机的配置

1.在与路由器连接的f0/12口开启trunk

Switch#

Switch#conf t

Enter configuration commands, one per line.   End with CNTL/Z.

Switch(config)#in f0/12

Switch(config-if)#switchport mode trunk

Switch(config-if)#exi

Switch(config)#exi

Switch#sh run

!

interface FastEthernet0/12

switchport mode trunk

backup interface

no fair-queue

!

2.划分vlan

Switch#vlan database

Switch(vlan)#vlan 10 name shichangbu

VLAN 10 added:

Name:shichangbu

Switch(vlan)#vlan 20 name xiaoshoubu

VLAN 20 added:

Name:xiaoshoubu

Switch(vlan)#vlan 30 name caiwubu

VLAN 30 added:

Name:caiwubu

Switch(vlan)#exi

APPLY completed.

Exiting....

3.将端口加入vlan

Switch#conf t

Enter configuration commands, one per line.   End with CNTL/Z.

Switch(config)#in range f0/1 - 3

Switch(config-range)#switchport mode access

Switch(config-range)#switchport access vlan 10

Switch(config-range)#exi

Switch(config)#in range f0/4 - 6

Switch(config-range)#switchport mode access

Switch(config-range)#switchport access vlan 20

Switch(config-range)#exi

Switch(config)#in range f0/7 - 9

Switch(config-range)#switchport mode access

Switch(config-range)#switchport access vlan 30

Switch(config-range)#exi

将各部门的计算机的ip和网关设置好以后,便可以互访了。

第二步 做ACL拒绝市场部和销售部访问财务部

R1(config)#access-list 101 deny ip 192.168.2.0 0.0.0.255 192.168.3.0 0.0.0.255

R1(config)#access-list 101 deny ip 192.168.1.0 0.0.0.255 192.168.3.0 0.0.0.255

R1(config)#access-list 101 permit ip any any

R1(config)#in f0/0.3

R1(config-subif)#ip access-group 101 in

R1(config-subif)#exi

R1(config)#exi

第三步 利用NAT的PAT技术让内部计算机上网

R1(config)#access-list 1 permit 192.168.1.0 0.0.0.255

R1(config)#access-list 1 permit 192.168.2.0 0.0.0.255

R1(config)#access-list 1 permit 192.168.3.0 0.0.0.255

R1(config)#ip nat inside source list 1 interface s1/0 overload

R1(config)#in f0/0

R1(config-if)#ip nat inside

R1(config-if)#exi

R1(config)#in s1/0

R1(config-if)#ip nat outside

R1(config-if)#exi

R1(config)#exi

-----摘自网络

  评论这张
 
阅读(3)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018